Netbeans IDE

Although not necessary, you may find convenient to use Netbeans (7.3. or higher) to work with the ActionGUI's plugin, since it supports very nicely maven projects. By using Netbeans IDE for modeling ActionGUI applications, you can take the advantages of the multiple developing features of one of the most famous IDEs.

Furthermore, we have developed three Netbeans textual editors for modeling the three different models of an ActionGUI application. These editors offers typical editor features (like syntax highlighting or brace matching), which eases the process of modeling ActionGUI applications. Next section shows a step-by-step guide of how to install the Netbeans textual editors for ActionGUI.